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Common Elements for ALL Documents 
Layout & Formatting 

  Use recommended fonts i.e., Times New Roman, 
Verdana, Arial, Tahoma, and Helvetica 

  Document Properties (Subject, Author, Title, 
Keywords, and Language) must be properly filled 
out.  Note:  Author name should be a government 
organization name (i.e., IHS). 
Hint: File > Properties 

  Table of Contents (TOC) or Bookmarks must be 
created using the TOC features available in the 
application.  TOC entries and bookmark links 
must be functioning correctly. 

  If there is no other way to make the content 
accessible (e.g., organizational chart), a separate 
accessible version must be provided. 

  All URL’s must contain the correct hyperlink and 
display the full qualified URL  
Example: http://www.samhsa.gov not 
www.samhsa.gov 

  Underlines are reserved for hyperlinks only. 
  Comments must be removed.  Track changes 

must be accepted or rejected and turned off. 
 Clear hierarchical structure must be utilized with 

Styles in the Styles and Formatting task pane. 
  WingDings are not acceptable bullets. 
  Utilize paragraph spacing instead of hard returns 

or tabs spacing. 
Hint:  Format > Paragraph 

  Utilize Page Breaks instead of hard returns to 
move text to the next page. 
Hint: Insert > Break > Page Break 

File Name 
  The file name must not contain spaces and/or 

special characters.  
Example:  CommonElements.doc 

  The file name must be concise and clear generally 
limited to 20-30 characters. 
Example: 508CompliancyJobAid.doc 

Images 
  Separate images/object/graphics that are meant 

to be one graphic image on a page must be 
grouped. 

  All images, graphics, grouped images and non-
text elements that convey information must have 
alternative text descriptions (ALT text). 
Hint: Right click > Format picture > Web Tab > fill 
out Alternative Text 

  Document content must refrain from 
flashing/flickering/animated text. 

Tables 
  Data tables must identify row and column headers 

starting with the first left hand column.  
  Merged cells should be avoided 
  Tables must have a logical reading order from left 

to right, top to bottom. 
  Tables must be used to create a table-like 

structure without the use of tabs or spaces. 
  All tables should be described and labeled.  Note: 

In some cases labeling a table may not be 
appropriate, such as; a small data table in a 
presentation may not need a label. 

 

.xls documents (Microsoft Excel) 
Layout & Formatting 

  Each worksheet must have an appropriate name 
in the tab at the bottom on the workbook. 

  Column and row headings must be labeled. 

Chart & Graphs 
  Charts and graphs must include axis information. 

Images 
  All images in the worksheets with informational 

value must include alternative text. 
Hint: Right click > Format picture > Web Tab > fill 
out Alternative Text 

  Decorative or background images must “Not” 
have alternative text added. 

  Ensure that tables spanning multiple pages have 
headings that associate with each page. 

http://www.samhsa.gov/
http://www.samhsa.gov/
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.pdf documents (Adobe Acrobat) 
Accessibility 

  Run a full Accessibility Report on the document in 
Adobe Acrobat professional 8 or higher.  Correct 
any errors reported, run the report, and repeat 
until the report shows no errors. 
Hint: Advanced > Accessibility > Full Check 

  Spot check document using the Adobe Acrobat 
Reader, Read Aloud function. Focus on multi-
column text and tables. 

  Perform a visual check on the document to ensure 
that no hidden data is present in the .pdf file. 

Images 
  The document should not contain scanned 

signature images. 
  Document should not contained scanned images 

of text. 

.doc documents (Microsoft Word) 
Layout & Formatting 

  Use Style element (i.e., Heading 1, Heading 2) or 
outline in a hierarchical manner. 

  Use automatic page numbering fields. 
  Create Footnotes using the Footnotes linking tool. 
  If color is used to emphasize the importance of 

selected text, is there an alternate method? 
  Provide an alternative method of emphasizing 

text, do not use color alone.  
Example: Color + Section 1.0 

  Use the automatic bullet lists available in the 
application.  Do not manually type lists preceded 
by special characters, such as hyphens or 
asterisks. 

  View the document in Print Preview and check to 
see if it flows correctly from page to page.  Look 
out for image placement, table format and 
stray/orphaned lines and characters. 

  Convert documents to pdf by using the Adobe 
PDF plug-in.  Do NOT use File > Print! 

Images 
  Complex images (i.e., charts and graphs) must 

have descriptive text immediately after the image. 
  Document must not have background images or 

watermarks. 
  Image Layout must be set “In Line with Text” for 

all images 
  Do not use text boxes for graphics or floating text. 

Tables 
  Tables that span multiple pages should have 

heading rows that repeat for each page. 
  In the Table Properties under the Row tab “Allow 

row to break across pages” must be unchecked 

.ppt documents (Microsoft PowerPoint) 
Layout & Formatting 

  All slide text must be viewable in the Outline View. 

Tables 
  Create all tables within the PowerPoint application 

Images 
  Avoid using text boxes for special graphics or text. 
  Decorative images (i.e., slide layout decorations) 

should have a blank Alternative text (i.e. “  “). 
  All charts must have a Title, Legend, and XY axis 

labels. 
  Complex images must have descriptive text 

available. 

More Information 
U.S. Department of Health & Human Services – 
Section 508 website - 
http://www.hhs.gov/web/508/index.html 
This Job Aid was originally developed by Indian 
Health Services 

http://www.hhs.gov/web/508/index.html


Section 508 - HTML Code 
The following are interpretations of the Section 508 standards for Web-based internet and 
intranet websites and how the Indian Health Service will address each via code example or 
explanation.  

(NOTE: Spacing inserted into the code examples are for display purposes only, spacing should be removed 
if you copy and paste this code into your web pages.)  

Graphics & Images 
Meaningful text descriptions must accompany non-text elements and convey the same 
information that is communicated by the associated element. A non-text element is an image, 
graphic, audio clip, or other feature that conveys meaning through a picture or sound. Examples 
include: elements that provide information required for comprehension of content or those used to 
facilitate navigation, buttons, check boxes, pictures and embedded or streaming audio or video.  
Code Example:  

< img src="images/graphic_image.gif" width="10" height="10" alt="Graphic Image description goes here">  

If a non-text element conveys no relevant information, i.e., a transparent graphic for spacing or a very small 
decorative image, the "alt" attribute must be present and can either contain a short text description or be 
empty/null."  

Code Example:  

< img src="images/graphi_image.gif" width="10" height="10" alt="">  

 

Multimedia Equivalents 
Equivalent alterative for any multimedia presentation shall be synchronized with the presentation. 
For IHS.gov this means we will caption our videos and for our flash animations we will have a 
textual version in the code and for the users who may not have flash.  

 

Color 
Color will not be used solely to represent anything on IHS.gov; a textual reference is also 
required. If something is noted as being a color it must also have be noted via a textual method. 
For instance, form fields that are required must have an asterisk (*) used as an indicator rather 
than just have text saying "form fields in red are required to be filled out".  
Example:  
* indicates a required field 
* First Name: [Form Field] 

 

Reading Order / Information Flow  
Websites need to have correct information flow. What this means is that if you were to look at the 
code of a page the content should go from top to bottom left to right as though you were reading 
a newspaper. If using CSS, make sure page content appears in correct order with CSS disabled. 
Use linked style sheets vs. embedded or inline styles, especially for font size. Use style sheets 
over the FONT tag.  

 

Server-side Image Maps  



When using server side image maps provide an overarching alt tag to the image describing what 
entirely is shown. On each mapped out piece of the image you need a unique alt tag that 
describes what that pieces is representing/showing.  
Code Example:  

< IMG src="images/botbar.jpg" alt="Site Navigation" usemap="#botbarMap39" > 
  < MAP NAME="botbarMap39" >  
    < AREA SHAPE="RECT" COORDS="1,22,50,45" HREF="about/about.html" alt="[About CIS]" >  
    < AREA SHAPE="RECT" COORDS="50,21,100,50" HREF="news/new.html" alt="[Cancer News]" >  
    < AREA SHAPE="RECT" COORDS="100,22,155,46" HREF="resources/resources.html" alt="[CIS 
Resources] ">  
    < AREA SHAPE="RECT" COORDS="155,22,218,47" HREF="http://www.cancer.gov/publications/" 
alt="[Publications Ordering]" >  
    < AREA SHAPE="RECT" COORDS="218,22,287,49" HREF="community/community.html" alt="[CIS 
Regional Programs]" > 
    < AREA SHAPE="RECT" COORDS="287,23,340,50" HREF="research/research.html" alt="[Cancer 
Research]" >  
    < AREA SHAPE="RECT" COORDS="340,23,375,48" HREF="maint/map/map.htm" alt="[Site Map]" >  
    < AREA SHAPE="RECT" COORDS="375,23,430,47" HREF="contact/contact.html" alt="[Contact Us]" >  
    < AREA SHAPE="CIRCLE" COORDS="445,21,22" HREF="index.html" alt="[Home]" >  
  < /MAP >  

 

Data Tables 
Data tables are tables used to present any information in a tabular format that isn't purely for 
formatting. Additionally, there must be a relationship with the column headings and row headings 
to the information in the table TDs. Use TH tags for data table headers. Include the ABBR 
attribute to provide a one word identifier the screen reader will announce as the header for each 
associated data cell. Use Summary attribute and CAPTION tag for all data tables.  
Code Example:  

< table summary = "Patient Registration Data" > 
  < tr> 
    < th scope="col">Clothing< /th> 
    < th scope="col">Size< /th> 
    < th scope="col">Cost in Dollars< /th> 
  < /tr> 
  < tr> 
    < th scope="row">Shirt< /th> 
    < td>Large< /td> 
    < td>1< /td> 
  < /tr> 
  < tr> 
    < th scope="row">Pants< /th> 
    < td>Medium< /td> 
    < td>6< /td> 
  < /tr> 
< /table> 

 

Frames 
Frames are not permitted on IHS.gov except for special circumstances. If a business need 
requires the use of frames it can be requested by contacting Web Services Management.  

 

Flickering 



IHS.gov web pages are not permitted to flicker or flash.  
 

Text-only Pages 
In situations where it is technically impossible to make something section 508 compliant a text-
only version of a page may be created. Web Services Management should be consulted prior to 
creating a text-only page.  

 

Scripting Languages 
Scripting languages, such as JavaScript, must have < noscript> text implemented. This text 
should be representative of what the scripts function is.  

 

Plug-in Applications 
When a web page requires that an applet, plug-in or other application be present on the client 
system to interpret page content, the page must provide a link to the respective plug-in or applet 
that is section 508 compliant. IHS.gov has built in template code that must be used to show the 
required plug-in(s). Additionally, only approved plug-in and applets may be used. These include:  

• Adobe Acrobat  
• Adobe Flash  
• Microsoft Office Suite (Word, Excel and PowerPoint)  
• Zip Files  

Note: We do provide legacy plug-ins for files that were posted prior to this standardization of content formats 
because older sites may still have these files available to download.  

 

Electronic Forms 
Form fields are required to have unique labels to be compliant. This allows for a relationship to be 
established as to what the form field is and what is required of the user.  
Code Example:  

< LABEL for="Duration" id="Durantion">How often do you visit this Web site?< /LABEL> 
  < select name="Duration" id="Duration"> 
    < option value=""> 
      < option value="301">This is my first visit< /option> 
      < option value="302">Daily< /option> 
      < option value="303">Weekly< /option> 
      < option value="304">Monthly< /option> 
  < /select>  

 

Skip Navigation  
Provide users a way to skip repetitive navigation links. In the standard IHS.gov template there are 
built in skip navigation locations. Our skip navigation is invisible to the general user but allows for 
screen reader users to skip over our header navigation and primary site navigation to the body 
content.  
Code Example:  

< a name="skipIHSfooter" href="#skipIHSheader" title="Skip IHS header, go to content">< /a> 
< a name="skipIHSheader" href="#">< /a> 



 

Time Responses 
If a timed response is programmatically determined there must be an option for more time. Auto 
forwarding after X seconds is not permissible on IHS.gov. 
 

Properly filling out the Document Properties in a Word Document 
 
Select File > Properties 



In the Properties window, 
click on the SUMMARY 
tab, fill in: 
• Title (Title of document 

not the file name) 
• Subject (document 
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